Open Source > sarama
Go

sarama

Sarama is a Go library for Apache Kafka 0.8, 0.9, and 0.10.

Sarama is an MIT-licensed Go client library for Apache Kafka version 0.8 (and later).

API documentation and examples are available via godoc.

Compatibility and API stability

Sarama provides a “2 releases + 2 months” compatibility guarantee: we support the two latest stable releases of Kafka and Go, and we provide a two month grace period for older releases. This means we currently officially support Go 1.7 and 1.6, and Kafka 0.10.0 and 0.9.0, although older releases are still likely to work.

Sarama follows semantic versioning and provides API stability via the gopkg.in service. You can import a version with a guaranteed stable API via http://gopkg.in/Shopify/sarama.v1. A changelog is available here.

Contributing

License

Copyright (c) 2015 Shopify. Released under the MIT-LICENSE.